Architectures/ARM/Release/13

From FedoraProject

Jump to: navigation, search

Fedora 13 ARM port

Since Fedora 13 ARM port is still being worked out, you may like to use mkrootfs to build your own root filesystem as described in the follwoing blog post:

http://paulfedora.wordpress.com/2010/12/15/fedora-13-arm-alpha-root-file-system/


Current rootfs status

Based on the list of packages from Fedora 12 ARM rootfs, following is the list of packages that needs to be available. Script used to generate the following content is here [1].

Package Name Current Status RPM Name
MAKEDEV needs packaging -
audit-libs packaged audit-2.0.4-3.fc13.armv5tel.rpm audit-libs-2.0.4-3.fc13.armv5tel.rpm
basesystem packaged basesystem-10.0-3.noarch.rpm
bash packaged bash-4.1.2-4.fc13.armv5tel.rpm bash-doc-4.1.2-4.fc13.armv5tel.rpm
binutils packaged binutils-2.20.51.0.2-23.fc13.armv5tel.rpm binutils-devel-2.20.51.0.2-23.fc13.armv5tel.rpm binutils-static-2.20.51.0.2-23.fc13.armv5tel.rpm
bzip2-libs packaged bzip2-1.0.6-1.fc13.armv5tel.rpm bzip2-devel-1.0.6-1.fc13.armv5tel.rpm bzip2-libs-1.0.6-1.fc13.armv5tel.rpm
ca-certificates packaged ca-certificates-2010-2.fc13.noarch.rpm
chkconfig packaged chkconfig-1.3.45-1.fc13.armv5tel.rpm
coreutils-libs packaged coreutils-libs-8.4-5.fc13.armv5tel.rpm
coreutils packaged coreutils-8.4-5.fc13.armv5tel.rpm coreutils-libs-8.4-5.fc13.armv5tel.rpm
cpio packaged cpio-2.10-6.fc13.armv5tel.rpm
cpp packaged cpp-4.4.4-14.fc13.armv5tel.rpm
cracklib-dicts packaged cracklib-dicts-2.8.15-3.fc13.armv5tel.rpm
cracklib packaged cracklib-2.8.15-3.fc13.armv5tel.rpm cracklib-devel-2.8.15-3.fc13.armv5tel.rpm cracklib-dicts-2.8.15-3.fc13.armv5tel.rpm cracklib-python-2.8.15-3.fc13.armv5tel.rpm
curl packaged curl-7.20.0-5.fc13.armv5tel.rpm
cyrus-sasl-lib packaged cyrus-sasl-2.1.23-11.1.fc13.armv5tel.rpm cyrus-sasl-lib-2.1.23-11.1.fc13.armv5tel.rpm
db4-utils packaged db4-utils-4.8.26-1.fc13.armv5tel.rpm
db4 packaged db4-4.8.26-1.fc13.armv5tel.rpm db4-cxx-4.8.26-1.fc13.armv5tel.rpm db4-devel-4.8.26-1.fc13.armv5tel.rpm db4-devel-static-4.8.26-1.fc13.armv5tel.rpm db4-tcl-4.8.26-1.fc13.armv5tel.rpm db4-utils-4.8.26-1.fc13.armv5tel.rpm
dhclient packaged dhclient-4.1.1-15.fc13.armv5tel.rpm dhcp-4.1.1-15.fc13.armv5tel.rpm
dirmngr packaged dirmngr-1.0.3-6.fc13.armv5tel.rpm
e2fsprogs-libs packaged e2fsprogs-libs-1.41.10-6.fc13.armv5tel.rpm
e2fsprogs packaged e2fsprogs-1.41.10-6.fc13.armv5tel.rpm e2fsprogs-devel-1.41.10-6.fc13.armv5tel.rpm e2fsprogs-libs-1.41.10-6.fc13.armv5tel.rpm
elfutils-libelf packaged elfutils-libelf-0.146-1.fc13.armv5tel.rpm
ethtool packaged ethtool-2.6.33-0.1.fc13.armv5tel.rpm
fedora-release needs packaging -
file-libs packaged file-libs-5.04-3.fc13.armv5tel.rpm file-5.04-3.fc13.armv5tel.rpm
filesystem packaged filesystem-2.4.31-1.fc13.armv5tel.rpm
findutils packaged findutils-4.4.2-6.fc13.armv5tel.rpm
fipscheck-lib packaged fipscheck-lib-1.2.0-4.fc13.armv5tel.rpm
fipscheck packaged fipscheck-1.2.0-4.fc13.armv5tel.rpm fipscheck-devel-1.2.0-4.fc13.armv5tel.rpm fipscheck-lib-1.2.0-4.fc13.armv5tel.rpm
gamin packaged gamin-0.1.10-6.fc13.armv5tel.rpm gamin-devel-0.1.10-6.fc13.armv5tel.rpm gamin-python-0.1.10-6.fc13.armv5tel.rpm
gawk packaged gawk-3.1.7-3.fc13.armv5tel.rpm
gcc packaged gcc-4.4.4-14.fc13.armv5tel.rpm gcc-c++-4.4.4-14.fc13.armv5tel.rpm gcc-gfortran-4.4.4-14.fc13.armv5tel.rpm gcc-java-4.4.4-14.fc13.armv5tel.rpm gcc-objc-4.4.4-14.fc13.armv5tel.rpm gcc-objc++-4.4.4-14.fc13.armv5tel.rpm
gdbm packaged gdbm-1.8.0-33.fc12.armv5tel.rpm
glib2 packaged glib2-2.24.1-1.fc13.armv5tel.rpm glib2-devel-2.24.1-1.fc13.armv5tel.rpm glib2-static-2.24.1-1.fc13.armv5tel.rpm
glibc-common needs packaging -
glibc-devel needs packaging -
glibc-headers needs packaging -
glibc needs packaging -
gmp packaged gmp-4.3.1-6.fc13.armv5tel.rpm gmp-devel-4.3.1-6.fc13.armv5tel.rpm gmp-static-4.3.1-6.fc13.armv5tel.rpm
gnupg2 packaged gnupg2-2.0.14-1.fc13.armv5tel.rpm gnupg2-smime-2.0.14-1.fc13.armv5tel.rpm
gpg-pubkey needs packaging -
gpgme needs packaging -
grep packaged grep-2.6.3-1.fc13.armv5tel.rpm
gzip packaged gzip-1.3.13-3.fc13.armv5tel.rpm
hwdata packaged hwdata-0.229-1.fc13.noarch.rpm
ifplugd needs packaging -
info packaged info-4.13a-9.fc13.armv5tel.rpm texinfo-4.13a-9.fc13.armv5tel.rpm
initscripts packaged initscripts-9.12.1-1.fc13.armv5tel.rpm
iproute packaged iproute-2.6.31-1.fc13.armv5tel.rpm iproute-doc-2.6.31-1.fc13.armv5tel.rpm
iptables packaged iptables-1.4.6-2.fc13.armv5tel.rpm iptables-devel-1.4.6-2.fc13.armv5tel.rpm iptables-ipv6-1.4.6-2.fc13.armv5tel.rpm
iputils packaged iputils-20071127-10.fc13.armv5tel.rpm
kernel-headers needs packaging -
keyutils-libs needs packaging -
krb5-libs needs packaging -
less packaged less-436-6.fc13.armv5tel.rpm
libacl needs packaging -
libattr needs packaging -
libblkid packaged libblkid-2.17.2-3.fc13.armv5tel.rpm libblkid-devel-2.17.2-3.fc13.armv5tel.rpm
libcap-ng packaged libcap-ng-0.6.2-4.fc13.armv5tel.rpm libcap-ng-devel-0.6.2-4.fc13.armv5tel.rpm libcap-ng-python-0.6.2-4.fc13.armv5tel.rpm libcap-ng-utils-0.6.2-4.fc13.armv5tel.rpm
libcap packaged libcap-2.17-1.fc13.armv5tel.rpm libcap-devel-2.17-1.fc13.armv5tel.rpm libcap-ng-0.6.2-4.fc13.armv5tel.rpm libcap-ng-devel-0.6.2-4.fc13.armv5tel.rpm libcap-ng-python-0.6.2-4.fc13.armv5tel.rpm libcap-ng-utils-0.6.2-4.fc13.armv5tel.rpm
libcom_err packaged libcom_err-1.41.10-6.fc13.armv5tel.rpm libcom_err-devel-1.41.10-6.fc13.armv5tel.rpm
libcurl packaged libcurl-7.20.0-5.fc13.armv5tel.rpm libcurl-devel-7.20.0-5.fc13.armv5tel.rpm
libdaemon needs packaging -
libffi packaged libffi-3.0.9-1.fc13.armv5tel.rpm libffi-devel-3.0.9-1.fc13.armv5tel.rpm
libgcc packaged libgcc-4.4.4-14.fc13.armv5tel.rpm
libgcrypt packaged libgcrypt-1.4.5-3.fc13.armv5tel.rpm libgcrypt-devel-1.4.5-3.fc13.armv5tel.rpm
libgomp packaged libgomp-4.4.4-14.fc13.armv5tel.rpm
libgpg-error packaged libgpg-error-1.7-1.fc13.armv5tel.rpm libgpg-error-devel-1.7-1.fc13.armv5tel.rpm
libidn packaged libidn-1.16-1.fc13.armv5tel.rpm libidn-devel-1.16-1.fc13.armv5tel.rpm
libksba packaged libksba-1.0.6-4.fc13.armv5tel.rpm libksba-devel-1.0.6-4.fc13.armv5tel.rpm
libselinux packaged libselinux-2.0.90-5.fc13.armv5tel.rpm libselinux-devel-2.0.90-5.fc13.armv5tel.rpm libselinux-python-2.0.90-5.fc13.armv5tel.rpm libselinux-ruby-2.0.90-5.fc13.armv5tel.rpm libselinux-static-2.0.90-5.fc13.armv5tel.rpm libselinux-utils-2.0.90-5.fc13.armv5tel.rpm
libsepol packaged libsepol-2.0.41-3.fc13.armv5tel.rpm libsepol-devel-2.0.41-3.fc13.armv5tel.rpm libsepol-static-2.0.41-3.fc13.armv5tel.rpm
libss packaged libss-1.41.10-6.fc13.armv5tel.rpm libss-devel-1.41.10-6.fc13.armv5tel.rpm libssh2-1.2.4-1.fc13.armv5tel.rpm libssh2-devel-1.2.4-1.fc13.armv5tel.rpm libssh2-docs-1.2.4-1.fc13.armv5tel.rpm
libssh2 packaged libssh2-1.2.4-1.fc13.armv5tel.rpm libssh2-devel-1.2.4-1.fc13.armv5tel.rpm libssh2-docs-1.2.4-1.fc13.armv5tel.rpm
libstdc++ packaged libstdc++-4.4.4-14.fc13.armv5tel.rpm libstdc++-devel-4.4.4-14.fc13.armv5tel.rpm libstdc++-docs-4.4.4-14.fc13.armv5tel.rpm
libudev packaged libudev-151-9.fc13.armv5tel.rpm libudev-devel-151-9.fc13.armv5tel.rpm
libusb needs packaging -
libuser packaged libuser-0.56.15-1.fc13.armv5tel.rpm libuser-devel-0.56.15-1.fc13.armv5tel.rpm libuser-python-0.56.15-1.fc13.armv5tel.rpm
libuuid packaged libuuid-2.17.2-3.fc13.armv5tel.rpm libuuid-devel-2.17.2-3.fc13.armv5tel.rpm
libxml2 packaged libxml2-2.7.6-1.fc13.armv5tel.rpm libxml2-devel-2.7.6-1.fc13.armv5tel.rpm libxml2-python-2.7.6-1.fc13.armv5tel.rpm libxml2-static-2.7.6-1.fc13.armv5tel.rpm
linux-atm-libs needs packaging -
logrotate packaged logrotate-3.7.8-7.fc13.armv5tel.rpm
lua needs packaging -
mingetty needs packaging -
module-init-tools packaged module-init-tools-3.11.1-1.fc13.armv5tel.rpm
mpfr packaged mpfr-2.4.2-1.fc13.armv5tel.rpm mpfr-devel-2.4.2-1.fc13.armv5tel.rpm
ncurses-base packaged ncurses-base-5.7-7.20100130.fc13.armv5tel.rpm
ncurses-libs packaged ncurses-libs-5.7-7.20100130.fc13.armv5tel.rpm
ncurses packaged ncurses-5.7-7.20100130.fc13.armv5tel.rpm ncurses-base-5.7-7.20100130.fc13.armv5tel.rpm ncurses-devel-5.7-7.20100130.fc13.armv5tel.rpm ncurses-libs-5.7-7.20100130.fc13.armv5tel.rpm ncurses-static-5.7-7.20100130.fc13.armv5tel.rpm ncurses-term-5.7-7.20100130.fc13.armv5tel.rpm
net-tools packaged net-tools-1.60-101.fc13.armv5tel.rpm
nspr packaged nspr-4.8.4-2.fc13.armv5tel.rpm nspr-devel-4.8.4-2.fc13.armv5tel.rpm
nss-softokn-freebl packaged nss-softokn-freebl-3.12.4-17.fc13.armv5tel.rpm nss-softokn-freebl-devel-3.12.4-17.fc13.armv5tel.rpm
nss-softokn packaged nss-softokn-3.12.4-17.fc13.armv5tel.rpm nss-softokn-devel-3.12.4-17.fc13.armv5tel.rpm nss-softokn-freebl-3.12.4-17.fc13.armv5tel.rpm nss-softokn-freebl-devel-3.12.4-17.fc13.armv5tel.rpm
nss-util packaged nss-util-3.12.6-1.fc13.armv5tel.rpm nss-util-devel-3.12.6-1.fc13.armv5tel.rpm
nss packaged nss-3.12.6-4.fc13.armv5tel.rpm nss-devel-3.12.6-4.fc13.armv5tel.rpm nss-pkcs11-devel-3.12.6-4.fc13.armv5tel.rpm nss-softokn-3.12.4-17.fc13.armv5tel.rpm nss-softokn-devel-3.12.4-17.fc13.armv5tel.rpm nss-softokn-freebl-3.12.4-17.fc13.armv5tel.rpm nss-softokn-freebl-devel-3.12.4-17.fc13.armv5tel.rpm nss-sysinit-3.12.6-4.fc13.armv5tel.rpm nss-tools-3.12.6-4.fc13.armv5tel.rpm nss-util-3.12.6-1.fc13.armv5tel.rpm nss-util-devel-3.12.6-1.fc13.armv5tel.rpm
openldap packaged openldap-2.4.21-3.fc13.armv5tel.rpm openldap-clients-2.4.21-3.fc13.armv5tel.rpm openldap-devel-2.4.21-3.fc13.armv5tel.rpm openldap-servers-2.4.21-3.fc13.armv5tel.rpm openldap-servers-sql-2.4.21-3.fc13.armv5tel.rpm
openssh-server packaged openssh-server-5.4p1-3.fc13.armv5tel.rpm
openssh packaged openssh-5.4p1-3.fc13.armv5tel.rpm openssh-askpass-5.4p1-3.fc13.armv5tel.rpm openssh-clients-5.4p1-3.fc13.armv5tel.rpm openssh-server-5.4p1-3.fc13.armv5tel.rpm
openssl packaged openssl-1.0.0-1.fc13.armv5tel.rpm openssl-devel-1.0.0-1.fc13.armv5tel.rpm openssl-perl-1.0.0-1.fc13.armv5tel.rpm openssl-static-1.0.0-1.fc13.armv5tel.rpm
pam packaged pam-1.1.1-4.fc13.armv5tel.rpm pam-devel-1.1.1-4.fc13.armv5tel.rpm pam_ssh_agent_auth-0.9.2-24.3.fc13.armv5tel.rpm
passwd packaged passwd-0.77-5.fc13.armv5tel.rpm
pcre needs packaging -
perl-Module-Pluggable packaged perl-Module-Pluggable-3.90-112.fc13.armv5tel.rpm
perl-Pod-Escapes packaged perl-Pod-Escapes-1.04-112.fc13.armv5tel.rpm
perl-Pod-Simple packaged perl-Pod-Simple-3.07-112.fc13.armv5tel.rpm
perl-libs packaged perl-libs-5.10.1-112.fc13.armv5tel.rpm
perl-version packaged perl-version-0.80-112.fc13.armv5tel.rpm
perl packaged perl-5.10.1-112.fc13.armv5tel.rpm perl-Archive-Extract-0.34-112.fc13.armv5tel.rpm perl-Archive-Tar-1.52-112.fc13.armv5tel.rpm perl-Compress-Raw-Zlib-2.023-112.fc13.armv5tel.rpm perl-Compress-Zlib-2.020-112.fc13.armv5tel.rpm perl-core-5.10.1-112.fc13.armv5tel.rpm perl-CPAN-1.9402-112.fc13.armv5tel.rpm perl-CPANPLUS-0.88-112.fc13.armv5tel.rpm perl-devel-5.10.1-112.fc13.armv5tel.rpm perl-Digest-SHA-5.47-112.fc13.armv5tel.rpm perl-ExtUtils-CBuilder-0.27-112.fc13.armv5tel.rpm perl-ExtUtils-Embed-1.28-112.fc13.armv5tel.rpm perl-ExtUtils-MakeMaker-6.55-112.fc13.armv5tel.rpm perl-ExtUtils-ParseXS-2.20-112.fc13.armv5tel.rpm perl-File-Fetch-0.20-112.fc13.armv5tel.rpm perl-IO-Compress-Base-2.020-112.fc13.armv5tel.rpm perl-IO-Compress-Zlib-2.020-112.fc13.armv5tel.rpm perl-IO-Zlib-1.09-112.fc13.armv5tel.rpm perl-IPC-Cmd-0.46-112.fc13.armv5tel.rpm perl-libs-5.10.1-112.fc13.armv5tel.rpm perl-Locale-Maketext-Simple-0.18-112.fc13.armv5tel.rpm perl-Log-Message-0.02-112.fc13.armv5tel.rpm perl-Log-Message-Simple-0.04-112.fc13.armv5tel.rpm perl-Module-Build-0.3500-112.fc13.armv5tel.rpm perl-Module-CoreList-2.18-112.fc13.armv5tel.rpm perl-Module-Load-0.16-112.fc13.armv5tel.rpm perl-Module-Load-Conditional-0.30-112.fc13.armv5tel.rpm perl-Module-Loaded-0.02-112.fc13.armv5tel.rpm perl-Module-Pluggable-3.90-112.fc13.armv5tel.rpm perl-Object-Accessor-0.34-112.fc13.armv5tel.rpm perl-Package-Constants-0.02-112.fc13.armv5tel.rpm perl-Params-Check-0.26-112.fc13.armv5tel.rpm perl-parent-0.221-112.fc13.armv5tel.rpm perl-Parse-CPAN-Meta-1.40-112.fc13.armv5tel.rpm perl-Pod-Escapes-1.04-112.fc13.armv5tel.rpm perl-Pod-Simple-3.07-112.fc13.armv5tel.rpm perl-suidperl-5.10.1-112.fc13.armv5tel.rpm perl-Term-UI-0.20-112.fc13.armv5tel.rpm perl-Test-Harness-3.17-112.fc13.armv5tel.rpm perl-Test-Simple-0.92-112.fc13.armv5tel.rpm perl-Time-Piece-1.15-112.fc13.armv5tel.rpm perl-version-0.80-112.fc13.armv5tel.rpm
pinentry needs packaging -
popt packaged popt-1.13-7.fc13.armv5tel.rpm popt-devel-1.13-7.fc13.armv5tel.rpm popt-static-1.13-7.fc13.armv5tel.rpm
procps packaged procps-3.2.8-6.fc13.armv5tel.rpm
psmisc needs packaging -
pth needs packaging -
pygpgme packaged pygpgme-0.1-17.20090824bzr68.fc13.armv5tel.rpm
python-iniparse needs packaging -
python-libs packaged python-libs-2.6.4-27.1.fc13.armv5tel.rpm
python-pycurl needs packaging -
python-urlgrabber needs packaging -
python packaged python-2.6.4-27.1.fc13.armv5tel.rpm python-devel-2.6.4-27.1.fc13.armv5tel.rpm python-libs-2.6.4-27.1.fc13.armv5tel.rpm python-test-2.6.4-27.1.fc13.armv5tel.rpm python-tools-2.6.4-27.1.fc13.armv5tel.rpm
readline packaged readline-6.1-2.fc13.armv5tel.rpm readline-devel-6.1-2.fc13.armv5tel.rpm readline-static-6.1-2.fc13.armv5tel.rpm
redhat-rpm-config needs packaging -
rootfiles needs packaging -
rpm-libs packaged rpm-libs-4.8.0-15.fc13.armv5tel.rpm
rpm-python packaged rpm-python-4.8.0-15.fc13.armv5tel.rpm
rpm packaged rpm-4.8.0-15.fc13.armv5tel.rpm rpm-build-4.8.0-15.fc13.armv5tel.rpm rpm-devel-4.8.0-15.fc13.armv5tel.rpm rpm-libs-4.8.0-15.fc13.armv5tel.rpm rpm-python-4.8.0-15.fc13.armv5tel.rpm
rsyslog packaged rsyslog-4.4.2-6.fc13.armv5tel.rpm rsyslog-gnutls-4.4.2-6.fc13.armv5tel.rpm rsyslog-gssapi-4.4.2-6.fc13.armv5tel.rpm rsyslog-mysql-4.4.2-6.fc13.armv5tel.rpm rsyslog-pgsql-4.4.2-6.fc13.armv5tel.rpm rsyslog-relp-4.4.2-6.fc13.armv5tel.rpm
sed packaged sed-4.2.1-4.fc13.armv5tel.rpm
setup needs packaging -
shadow-utils packaged shadow-utils-4.1.4.2-2.fc13.armv5tel.rpm
sqlite packaged sqlite-3.6.22-1.fc13.armv5tel.rpm sqlite-devel-3.6.22-1.fc13.armv5tel.rpm sqlite-doc-3.6.22-1.fc13.armv5tel.rpm sqlite-tcl-3.6.22-1.fc13.armv5tel.rpm
sysvinit-tools needs packaging -
tar packaged tar-1.22-17.fc13.armv5tel.rpm
tcp_wrappers-libs needs packaging -
tzdata needs packaging -
udev packaged udev-151-9.fc13.armv5tel.rpm
upstart packaged upstart-0.6.5-5.fc13.armv5tel.rpm
util-linux-ng packaged util-linux-ng-2.17.2-3.fc13.armv5tel.rpm
vim-minimal needs packaging -
wget packaged wget-1.12-2.fc13.armv5tel.rpm
xz-libs needs packaging -
yum-metadata-parser needs packaging -
yum needs packaging -
zlib needs packaging -