Archive:PackagingDrafts/DropScrollkeeperUpdate

From FedoraProject

Jump to: navigation, search

Drop Scrollkeeper Update Scriptlets

Since Fedora 8, scrollkeeper has been obsoleted by rarian. As a result of this change, the scrollkeeper-update script is now a noop, only provided for compatibility purposes.

scrollkeeper --help states:

NOTE (2): This script doesn't do anything and is only provided for scrollkeeper compatibility

In Packaging:ScriptletSnippets#Scrollkeeper, the %post and %postun scriptlets call scrollkeeper-update, but this is obviously no longer necessary. These scriptlets should be removed from the Packaging:ScriptletSnippets#Scrollkeeper section, a new section should be created on Packaging:EPEL (since they are still needed on EL-4 and EL-5), and a link placed to the EPEL section on the Packaging:ScriptletSnippets#Scrollkeeper section.