Features/Php55

From FedoraProject

Jump to: navigation, search


Contents

PHP 5.5

Summary

To provide the latest PHP stack.

Owner

  • Name: Remi Collet
  • Email: remi AT SPAMFREE fedoraproject DOT org

Current status

  • Targeted release: Fedora 19
  • Last updated: 2013-05-09
  • Percentage of completion: 100%
  • 2013-02-21 beta1 released, upstream feature freeze.
  • 2013-02-22 Rebuild done in rawhide
  • 2013-02-23 Rebuild done in Fedora 19

Detailed Description

  • PHP 5.5.0beta1 is released (Mar 21th) FEATURE FREEZE
  • PHP 5.5.0beta2 is released (Mar 28th)
  • PHP 5.5.0beta3 is released (Apr 11th)
  • PHP 5.5.0beta4 is released (Apr 25th)
  • PHP 5.5.0RC1 is released (May 9th)
  • PHP 5.5.0RC2 is released (May 23th)
  • PHP 5.5.0RC3 is released (June 6th)
  • PHP 5.5.0 Finale is released (June 20th)

Finale version (Q1/2013) should be available before fedora 19 (Q2/2013).

  • Roadmap is delayed by a month, because of ZendOptimizerPlus code to be merged with php core.

Planed packaging changes

Build more extensions shared for flexibility

  • in php-common: bz2, calendar, ctype, exif, ftp, gettext, iconv, sockets and tokenizer
  • moved in php-gmp: gmp
  • moved in php-process: shmop
  • moved in php-xml: xml and simplexml

Drop libmysqlclient driver and only provide mysqlnd driver (this doesn't change mysql/mysqli extensions which can use both)

Drop json non-free extension (php-pecl-jsonc provides an alternative)

Add opcache extension (ZendOptimizer+, official upstream opcode cache) and remove opcode feature from APC (only kept for user data cache)

Activate dtrace/systemtap <sys/sdt.h> markers

Benefit to Fedora

Provides the latest PHP version.

Scope

  • Mass rebuild of all packages which requires php ABI, some will requires update or patch
  • Test of web applications

How To Test

  • test PHP web applications available in the repository

User Experience

Web developer will get the latest upstream PHP version

Dependencies

From repoquery --whatrequires 'php(zend-abi)'

Rebuild done:

  • php-5.5.0-0.1.beta1.fc19
  • graphviz-2.30.1-3.fc19
  • ice-3.5-0.4.b.fc19 (ice-php)
  • libdigidocpp-0.3.0-18.fc19 (php-digidoc)
  • libkolab-0.4.2-1.fc20 (php-kolab)
  • libkolabxml-0.8.3-2.fc19 (php-kolabformat)
  • libpuzzle-0.11-17.fc19 (php-libpuzzle)
  • maniadrive-1.2-54.fc19
  • php-facedetect-1.0.1-9.fc19
  • php-idn-1.2c-8.fc19
  • php-libvirt-0.4.5-4.fc19
  • php-magickwand-1.0.9-6.fc19
  • php-pecl-amqp-1.0.9-4.fc19
  • php-pecl-apc-3.1.15-0.2.svn329724.fc19
  • php-pecl-cairo-0.3.2-3.fc19
  • php-pecl-gearman-1.1.1-1.fc19
  • php-pecl-geoip-1.0.8-5.fc19
  • php-pecl-gmagick-1.1.0-0.8.RC2.fc19
  • php-pecl-http-2.0.0-0.16.beta4.fc19
  • php-pecl-igbinary-1.1.2-0.5.git3b8ab7e.fc19
  • php-pecl-imagick-3.1.0-0.6.RC2.fc19
  • php-pecl-lzf-1.6.2-4.fc19
  • php-pecl-mailparse-2.1.6-4.fc19
  • php-pecl-memcache-3.0.7-7.fc19
  • php-pecl-memcached-2.1.0-7.fc19
  • php-pecl-mongo-1.3.5-1.fc19
  • php-pecl-mysqlnd-ms-1.4.2-3.fc19
  • php-pecl-mysqlnd-qc-1.2.0-2.fc19
  • php-pecl-ncurses-1.0.2-4.fc19
  • php-pecl-oauth-1.2.3-3.fc19
  • php-pecl-parsekit-1.3.0-3.fc19
  • php-pecl-radius-1.2.5-16.fc19
  • php-pecl-rrd-1.1.0-3.fc19
  • php-pecl-runkit-1.0.4-0.3.GIT8c73eaf.fc19
  • php-pecl-selinux-0.3.1-11.fc19
  • php-pecl-solr-1.0.2-6.fc19
  • php-pecl-sphinx-1.2.0-1.fc19
  • php-pecl-ssh2-0.12-1.fc19
  • php-pecl-uuid-1.0.3-5.fc19
  • php-pecl-xdebug-2.2.2-0.1.gitb1ce1e3.fc19
  • php-pecl-xhprof-0.9.2-10.gitb8c76ac5ab.fc19
  • php-pecl-yaml-1.1.0-4.fc19
  • php-redis-2.2.2-7.git6f7087f.fc19
  • php-shout-0.9.2-14.fc19
  • php-xcache-3.1.0-0.1.svn1234.fc19
  • php-zmq-0.6.0-10.20120613git516bd6f.fc19
  • redland-bindings-1.0.13-3.fc19 (php-redlands)
  • remctl-3.3-4.fc19
  • rrdtool-1.4.7-13
  • syck-0.70-1 (syck-php)
  • uuid-1.6.2-17.fc19
  • uwsgi-1.2.6-10 (uwsgi-plugin-php)
  • zorba-2.8.0-4.fc19

Not rebuild yet:

  • mapserver (php-mapserver): FTBFS
  • zarafa (php-mapi): FTBFS, broken dep in BR

Contingency Plan

Work in a dedicated build target. Merge only when all is ok.

There is some risk that finale version not released at f19 time, but in case, we'll ship a RC.

Compatibility with previous PHP 5.4 is rather good.

Documentation

Release Notes

Fedora 19 includes version 5.5.0 of PHP. This includes a number of significant new features, including support for Generators, new Zend OPcache extension as well as a number of performance enhancements. For complete details see Migrating from PHP 5.4.x to PHP 5.5.x.

Comments and Discussion

For discussion, please join the php devel ML