User:Stevetraylen

From FedoraProject

Jump to: navigation, search

Email: steve.traylen@cern.ch

Employer: http://cern.ch/

Current Fedora Aims

  • Get lots of grid software into Fedora and EPEL
  • I've set up a Fedora Grid Computing special interest group.

Things I need to do

  • Get perl-POE-Component-Client-LDAP into EPEL.
  • Get perl-WWW-Mechanize into EPEL.

Things that I can't build in EPEL6

  • xml-security-c, xmltooling, opensaml missing xalan-c
  • plpa no EL6 branch why?
  • xcalc , needs some work.

python26 rpms for EPEL5

Since python26 is about to be added to EPEL5 there are bunch of python packages that I'm interested to see appear. Some of these will I'm sure never happen but recorded here anyway.

Silas has some .spec file here as well: https://github.com/opsdojo/rpms/tree/master/src/el/5/opsdojo-python26

List of python26 packages
Package Name Notes
ipython Looks to be a bit of a pain needing python-simplegeneric, python-foolscap, python-twisted-core, python-zope-interface, python-configobj , python-mglob pexpect and python-pretty
python-pip
Django Requires a number of packages, Dependency tree https://bugzilla.redhat.com/showdependencytree.cgi?id=662758&hide_resolved=0
mod_python Released https://admin.fedoraproject.org/updates/python26-mod_python
plone
python-fpconst
python-simplejson Released https://admin.fedoraproject.org/updates/python26-simplejson
python-nose Release
python-soap
python-cherrypy
cx_Oracle Will never be added to EPEL but here since I will do for my own purposes.
python-sqlite Probably already included in python26 distribution
setuptools Released as python26-distribute, provides python26-setuptools.
SOAPpy Requires PyXML.
ZSI Release in a couple of weeks or so: https://admin.fedoraproject.org/updates/python-ZSI-2.0-7.el5
PyXML Will be released very shortly https://admin.fedoraproject.org/updates/python26-PyXML
virtualenv Now released, : https://bugzilla.redhat.com/show_bug.cgi?id=673545
python-curl Review submitted: https://bugzilla.redhat.com/show_bug.cgi?id=682553
4Suite-XML
scipy Needs numpy.
matplotlib Needs numpy.
numpy Review progressing well, https://bugzilla.redhat.com/show_bug.cgi?id=619355