From Fedora Project Wiki

(Packages that are done)
Line 18: Line 18:
  
 
=== Packages that are done ===
 
=== Packages that are done ===
* aqute-bndlib - update to version containing aqute.libg.header.OSGiHeader class ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130514 build])
+
* <s>aqute-bndlib - update to version containing aqute.libg.header.OSGiHeader class</s> ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130514 build])
* felix-osgi-core - new package ([https://bugzilla.redhat.com/show_bug.cgi?id=521067 review request]) ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130516 build])
+
* <s>felix-osgi-core - new package ([https://bugzilla.redhat.com/show_bug.cgi?id=521067 review request])</s> ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130516 build])
* kxml - new package ([https://bugzilla.redhat.com/show_bug.cgi?id=521064 review requiest]) ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130518 build])
+
* <s>kxml - new package ([https://bugzilla.redhat.com/show_bug.cgi?id=521064 review requiest])</s> ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130518 build])
* slf4j - new package ([https://bugzilla.redhat.com/show_bug.cgi?id=520808 review request]) ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130519 build])
+
* <s>slf4j - new package ([https://bugzilla.redhat.com/show_bug.cgi?id=520808 review request])</s> ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130519 build])
* felix-osgi-obr - new package ([https://bugzilla.redhat.com/show_bug.cgi?id=521069 review request]) ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130559 build])
+
* <s>felix-osgi-obr - new package ([https://bugzilla.redhat.com/show_bug.cgi?id=521069 review request])</s> ([http://koji.fedoraproject.org/koji/buildinfo?buildID=130559 build])
  
 
=== Packages that need work and/or reviews ===
 
=== Packages that need work and/or reviews ===

Revision as of 08:36, 4 September 2009

Jetty Update

There is a lot of work to do to update the version of Jetty in Fedora.

Jetty 6.1.*

We plan to update Jetty to the latest 6.1 release and should be ready in time for Fedora 12. The main tracker bug is bug 486360. Be sure to file any issues that are a part of this work as blockers of that bug.

In order to build some of the packages below that are higher up the dependency chain, you will need some of the packages lower on the dependency chain. If a simple yum --enablerepo=rawhide install of the packages you need doesn't work, you can try the repository of just-built packages, adjusting for your architecture as appropriate:

[koji]
name=Fedora 12 - i386
baseurl=http://koji.fedoraproject.org/static-repos/dist-f12-build-current/i386
enabled=0

and then use yum --enablerepo=koji install


Packages that are done

Packages that need work and/or reviews

  • maven-bundle-plugiin - new package

Jetty 7

This is the version of Jetty with release planned for 2009-09-08.