From Fedora Project Wiki


Remove Obsolete Scriptlets

Summary

Remove scriptlets which are not needed anymore (ldconfig, gtk-update-icon-cache, etc.).

Owner

  • Name: Igor Gnatenko
  • Email: ignatenkobrain@fedoraproject.org
  • Release notes owner:

Current status

Detailed Description

There are plenty of scriptlets which were needed at time of Fedora 28 or earlier which are not needed anymore and just slow down installation. We will remove scriptlets which are not needed anymore from packages.

  • ldconfig scriptlets will be replaced by %ldconfig_scriptlets macro
  • gtk-update-icon-cache, glib-compile-schemas, gdk-pixbuf-query-loaders, gtk-query-immodules-3.0, gio-querymodules and install-info scriptlets will be removed entirely

Benefit to Fedora

  • Smaller installation time of RPMs.
  • Faster image building/buildroot preparation/etc. (from RPMs).

Scope

  • Proposal owners: Find appropriate packages and remove obsolete scriptlets.
  • Other developers: Package Maintainers are advised to remove scriptlets themselves or wait until Proposal Owners will do that.
  • Release engineering: #7977 (to avoid multiple rebuilds, completing this change before mass rebuild is advised)
  • Policies and guidelines: Guidelines are already updated.
  • Trademark approval: N/A (not needed for this Change)

Upgrade/compatibility impact

Installed F30 RPMs on F28/EL6/EL7 might not work although it is not supported.

How To Test

Install new version of package with removed scriptlets and observe that it works.

User Experience

Installation of packages are faster.

Dependencies

No specific dependencies.

Contingency Plan

  • Contingency mechanism: Proposal Owners will revert changes which break specific packages when encountered.
  • Contingency deadline: Final freeze.
  • Blocks release? No
  • Blocks product? product

Documentation

Everything is already documented in Packaging Guidelines.

Release Notes