F11 User Guide - Office Tools

From FedoraProject

Jump to: navigation, search

Contents

Office Tools

There are two primary office suite recommendations for Fedora users: the OpenOffice.org suite which is not desktop or even Linux specific, and the KOffice suite for the KDE desktop. Each suite of office tools includes presentation, spreadsheet, and word processing applications. Additional office applications are also available depending on the office suite selected.

While the GNOME desktop does not have a specific office suite, there are a number of office application optimized for GNOME. A few other programs of interest are Abiword, a word processing application that has plug-ins to make presentations and graphs, Gnumeric, a spreadsheet application, and gLabels, a program for creating labels and business cards.

Remember any office application or suite will run on any Fedora desktop environment. The recommendation is only the office suite best optimized for a specific desktop environment, such as GNOME or KDE. Once installed, all office tools are available from the Applications > Office menu or as icons located in the menu bar or on the desktop.

OpenOffice.org Applications

OpenOffice.org creates documents in open standards formats, such as OpenDocument (.ODF), Rich Text Format (.RTF), and HyperText Markup Language (HTML). It can also read, edit, and write documents in Microsoft Office formats, such as Word (.DOC), Excel (.XLS), and PowerPoint (.PPT), with a high degree of compatibility. Files can be exported in PDF format without the need of additional software. The most used Openoffice.org programs are: Impress, Calc, and Write.

For more information on using OpenOffice.org, refer to the following documentation and support pages:


OpenOffice.org Impress

Docs Drafts DesktopUserGuide Office openofficeorg-impress.png OpenOffice.org Impress Creates and performs presentations.

  • Start the application by clicking on Applications > Office > OpenOffice.org Impress.
  • The first window asks you to choose Empty presentation, From template, or Open existing presentation.
  • Select Empty presentation to build your slide(s) from scratch, or
  • The [From Template] button for further configuration:
  • Presentations allow you to choose:
  • Default
  • Introducing a New Product
  • Recommendation of a Strategy
  • Presentation Backgrounds loads the window with several background choices.
  • Open existing presentation opens a presentation file.
  • Choose the [Next] key to Select a slide design and Select an output medium.
  • Another click on [Next] opens the Presentation Wizard to set up your presentation. You can select the Effect and Speed of slide transition, and either Default or Automatic for the Type of Presentation you want.
  • When building a presentation from a template there may be additional pages of questions such as the subject of the presentation or company name or the number of starting slides.
  • The[Create] button opens your presentation.
  • The application opens with the work area, top menu and a drawing menu on the bottom. When you roll your mouse over the icons a description of its function pops up.
  • Select Help, or press the [F1] key, to open the OpenOffice.org Impress help manual.

For details on using OpenOffice.org Impress. see this Tutorial

OpenOffice.org Calc

Docs Drafts DesktopUserGuide Office openofficeorg-calc.png OpenOffice.org Calc is a full featured spreadsheet program.

  • Start the application by clicking on Applications > Office > OpenOffice.org Calc.
  • Major functions of the top menu are:
  • File lets you create New documents, Open and Close a file, Export and Print. It has the Wizards link to create different templates.
  • Edit allows you to Cut, Copy, and Paste, Delete Cells and Spreadsheets, and to Copy and Move Spreadsheets.
  • View lets you select Toolbars, see Page Breaks, and Zoom in and out.
  • With the Insert button you can insert Cells, Rows, Sheets, Files, Pictures, Sounds, Functions, Special Characters, and Links.
  • Under Format the Cells, Rows, Columns, and Sheet can be formatted, set-up the Page and Print Ranges. Change Case and Styles. It also provides the ability to Anchor, Align, Arrange, Flip, Group, and manipulate Graphics.
  • Tools can check Spelling, access the Thesaurus, use the filters Detective, Goal Seek, Solver, and Scenarios. Configure AutoCorrect, Share, Merge, and Protect the document. You can run Macros, Extension Manager, Customize the application, and set-up various Options.
  • Selecting Data you can manipulate the data such as Define or Select Range, Sort, Filter, and Group and Outline.
  • The Window key lets you open a New Window, Close Window, and Split or Freeze the current window. It also lists any open files on the bottom of the drop-down menu.
  • Select Help, or press the [F1] key, to open the OpenOffice.org Calc help manual.
  • The row of icons under the top menu bar contains the most frequently used functions plus a few icons for data manipulation.
  • The third menu panel allows you to configure the appearance of your data, such as font selection, alignment, font, bullets, indentations, bolding, and italicizing.
  • The fourth panel shows the address of the cell you are pointing to and the data window shows what the cell contains.
  • The panel at the bottom of the spreadsheet shows which spreadsheet is currently selected and how many worksheets are in the file.
  • Worksheets can be added by going to the top menu panel and clicking on Insert > Sheet > [OK] button, or choose where you want the new spreadsheet placed, the number of spreadsheets you want, and the name if you want something other than the default.
  • A right mouse click on a spreadsheet tab brings up a short menu that allows you to Insert, Delete, Rename, Move/Copy, Select All, Cut, or Copy the spreadsheet.

For details on using OpenOffice.org Calc. see this Tutorial

OpenOffice.org Writer

Docs Drafts DesktopUserGuide Office openofficeorg-writer.png OpenOffice.org Writer is a word processing program.

  • Start the application by clicking on Applications > Office > OpenOffice.org Writer.
  • Major functions of the top menu are:
  • File lets you create New documents, Open and Close a file, Export and Print. It has the Wizards link to create different templates.
  • Edit allows you to Cut, Copy, and Paste, Compare, Select Text, turn on and configure Auto-Text, Find and Replace. and Changes recording, protecting, comparing and merging.
  • View lets you select the type of Layout, Status Bar, Ruler, Toolbars, Text Boundaries, Field Names, Non-printing Characters, Hidden Paragraphs, Full Screen and Zoom in and out.
  • With the Insert button you can insert Manual Breaks, Fields, Special Characters, Formatting Marks, Hyperlinks, Headers, Footers, Footnotes, Bookmarks, Note, Scripts, Cross-reference, Indexes, and Tables, Envelopes, Tables, Horizontal Ruler, Pictures, Movies and Sound, Objects, Floating Frames, and Files.
  • Under Format you can format Characters, Paragraphs, Bullets and Numbering, Page, Title Page, Change Case, configure Columns, Styles and Formatting. You can also Anchor, Wrap, Align, Flip, and Group text, and format Objects, Frames, and Pictures.
  • Tables allows you to Insert, Delete, Select, and manipulate the Table's Cells. You can also format a Table's Cells, Rows and Columns, add Formulas and access a Table's Properties.
  • Selecting Tools gives you access to Spelling and Grammar, Language (which includes Thesaurus), Word Count, Auto correction, Outline and Line Numbering, Footnotes, Gallery, Media Player, Bibliography Database, and Mail Merge Wizard. You can also Sort, Calculate, change and format Macros and Filters, Customize Menus, Keyboard, Toolbars and Events. Options lets you configure your User Data.
  • The Window key lets you open a New Window, Close Window, and lists any open files on the bottom of the drop-down menu.
  • Select Help, or press the [F1] key, to open the OpenOffice.org Writer help manual.
  • The row of icons under the top menu bar contains the most frequently used functions plus a few icons for data manipulation.
  • The third menu panel allows you to configure the appearance of your document, such as font selection, alignment, font, bullets, indentations, bolding, and italicizing.
  • The panel at the bottom of the document contains inset windows, some of which have menu access by double clicking on the window. This panel showns the number of pages the document contains, the page style being used, the language, indicator of Type-Over or Insert, page layout view, and a zoom in and out bar.

For details on using OpenOffice.org Writer see this Tutorial.

For the most up-to-date information on all of OpenOffice.org's office program offerings, visit the official site OpenOffice.org.

Also see:

KOffice

The KOffice suite is optimized for the KDE desktop environment. The KOffice applications also create documents and files in open standards formats including OpenDocument (.ODF), Rich Text Format (.RTF), and HTML. Officially, the KOffice FAQ recommends using .RTF or .PDF formats for compatibility with Microsoft Word. KOffice does support Microsoft file formats, but there are issues with compatibility.

For the most up-to-date information on all of KOffice's program offerings, visit the official KOffice site. This site also includes detailed documentation and help for each individual KOffice program.

For more information on using KOffice, refer to the following documentation and support pages:

KPresenter

Docs Drafts DesktopUserGuide Office kpresenter.png KPresenter is the KOffice application for creating and performing presentations.

  • Open Kpresenter by selecting the Kickoff Application Launcher > Office > Slide Presentations (KPresenter).
  • The first window contains options for opening Recent or Existing documents, the type of Template or Screen Presentation you want, as well as a menu bar.
  • On the menu bar, chose File to create a New file, Open or Import a file, or Quit the application.
  • On the Settings drop-down menu select Show Toolbar, Configure Shortcuts or Configure Toolbars.
  • Help, or the [F1] button, opens the KPresenter Handbook, and Report a Bug.
  • After selecting the desired Template click the [Use This Template] button and check the box Always use this template if you want to make it the program default.
  • The next window has three menu panels on the top, a workspace with three windows, and a panel running along the bottom.
  • The first menu row consists of:
  • File which allows you to create a New file, Open, Save, Import, Export, and Mail files. You can Create an HTML Slideshow or Memory Stck Slideshow, use the Template Manger, Use Current Slide as Default Template, Print, Preview, Close, or Quit the presentation.
  • Edit drop-down lets you Undo, Redo, Cut, Copy Paste, Delete, Select All, Deselect, Find, Replace, Copy Slide, Duplicate and Delete a Slide, and to Duplicate an Object.
  • In the View menu select New View, Close All Views, Split View, Remove View, Hide the Sidebar, Notebar, or Slide Master. It also allows Formatting of Characters, to show or hide Guide Lines, Grid, and the Snap to Grid, and Zoom in or out. When you select these options they show up in the work area windows.
  • Insert allows additions of Special Character, Variable, Link, Comment, Slide, File, Text, Chart, Table, Object, Picture, Line, Shape, or Scan Image.
  • Under Format select Rotate, Zoom, adjust the Properties, Arrange, Align, Group, Ungroup and Shadow Objects. Here you can also change the Page Layout, Slide Background, and Enable Document Headers and Footers.
  • Choose Text to switch to the Default Format, select Fonts, configure Paragraphs and color. The Style Manager lets your create your own styles or you can choose Style which lists the available styles. You can also Align the text, chose to add Numbers or Bullets by selecting Type. There are options to manipulate an Object, Change Case, turn on, or off, the Auto Spellcheck and Autocorrection.
  • Slide Show allows configuration of the Slide Show, Objects, and Slide Transition. In this menu you can Start and Customize the slide show, and navigate the presentation manually.
  • Settings menu lets you choose the Toolbars you want to use, you can Configure Autocorrection, Completion, Shortcuts, Toolbars, and KPresenter.
  • Select Help, or press the [F1] key, to open the KPresenter Handbook or you can Report a Bug and get general information about KPresenter and KDE.
  • The second row contains icons that are shortcuts of the top menu panel for File, Insert, Drawing, and Object formatting. Rolling you mouse over an icon opens a small window that lists it's function.
  • The third menu panel is also made up of shortcut icons to work with Text and Slideshow configuration and navigation. Many of the icons in the menu panels are grayed-out until a selection is made on the slide in the work area window.
  • The bottom panel shows the Slide number currently being worked on and the number of slides in the presentation, Main Slide Content or attributes, the Zoom percentage, and current measurement, Centimeters or Inches.

For details on using KPresenter see this Tutorial

Pre-Formatted templates can be downloaded from KPresenter Templates.

KSpread

Docs Drafts DesktopUserGuide Office kspread.png KSpread is the KOffice spreadsheet program.

  • Open KSpread by selecting the Kickoff Application Launcher > Office > Spreadsheets (KSpread).
  • The first window contains options of opening a Recent document, selecting the type of Template you want, as well as a menu bar.
  • On the menu bar, chose File to create a New file, Open or Import a file, or Quit the application.
  • On the Settings drop-down menu select Show Toolbar, Configure Shortcuts or Configure Toolbars.
  • Help, or the [F1] button, opens the KSpread Handbook, and Report a Bug.
  • After selecting the desired Template click the [Use This Template] button and check the box Always use this template if you want to make it the program default.
  • The next window has four menu panels on the top, the spreadsheet, and spreadsheet tabs running along the bottom.
  • The first menu row consists of:
  • File to create New documents, Open and Close a file, Save, Export, Import, Mail, Create a Template From Document, Print, and Quit the application.
  • Edit allows Cut, Copy, and Paste, Fill, Find and Replace, Delete, Remove Links and change Cell Attributes.
  • View opens a new spreadsheet with New View, or allows access to Close All Views, Split or Remove View, Goto a Cell, Show Page Borders, and Zoom in and out.
  • Use the Insert menu to insert Cell Comments, Functions, Series, Links, Special Characters, Objects, Charts, Pictures, or External Data such as information from a Database, Text File or the Clipboard.
  • Under Format the Cells, Rows, Columns, can be formatted, the Sheet can be Removed, Hidden and the Sheet Properties changed. Format can also be used to set-up or create Styles, change the Page Layout and Print Ranges.
  • Select Data to manipulate the data such as Sort bring Text to Columns, Insert columns, Rows, Delete Columns or Rows, Insert, Remove, Merge, or Disassociate Cells, Show an Area, insert Subtotals, Goal Seek, or Consolidate formulas.
  • Tools can check Spelling, create Custom Lists, Protect Sheet and Document, Recalculate Sheet or Document, Insert Calendar. Tools can also access the Script Manager and Editor, and Export to HTML File.
  • The Settings tab provides Hide the Status Bar, Tab Bar, and Formula Bar. Also use Settings to choose which Toolbars you want open, Configure Shortcuts, Toolbars, and KSpread.
  • Select Help, or press the [F1] key, to open the KSpread Handbook or Report a Bug and get general information about KSpread and KDE.
  • The row of icons under the top menu bar contains the most frequently used functions plus a few icons for data manipulation.
  • The third menu panel allows configuration of the appearance of your data, such as font selection, alignment, font, bullets, indentations, bolding, and italicizing.
  • The fourth panel shows the address of the current cell and the data window shows what the cell contains.
  • The panel at the bottom shows in Bold which spreadsheet is currently selected and how many worksheets are in the file.
  • Worksheets can be added with a right mouse click on a worksheet [Tab]. This pop-up window allows Rename the Sheet, Insert, Remove, Hide or Show the Sheet and provides access to Sheet Properties.

For details on using KSpread see this Tutorial.

You can download these KSpread templates and Scripts.

KWord

Kword-f10.png KWord is the KOffice word processing program.

  • Open KWord by selecting the Kickoff Application Launcher > Office > Word Processing (KWord).
  • The first window contains options of opening New, Recent or Existing documents, the type of Template you want, as well as a menu bar.
  • On the menu bar, chose File to create a New file, Open or Import a file, or Quit the application.
  • On the Settings drop-down menu you can select Show Toolbar, Configure Shortcuts or Configure Toolbars.
  • Help, or the [F1] button, opens the KWord Handbook, and Report a Bug.
  • After you have selected the desired Template click the [Use This Template] button and check the box Always use this template to make it the program default, if you desire.
  • The next window has three menu panels on the top, Frame shortcut icons on the left, the Document Structure window, the document work area, and an information panel running along the bottom.
  • The first menu row consists of:
  • File lets you create New documents, Open and Close a file, Save, Export, Import, Mail, Create a Template From Document, Print, and Close the file or Quit the application.
  • Edit allows you to Undo, Redo, Cut, Copy, Paste, Select All, All Frames or a single Frame. You can also Find, Replace, and Delete Page.
  • View lets you open a new document with New View, Close All Views, Split or Remove View, Display Mode for Page, Preview, and Text Modes. You can Format Characters, choose Frame Borders, Hide Doc Structure and Rulers, Show Grid, Snap to Grid, and Zoom in and out.
  • With the Insert button you can insert Special Characters, Page Breaks, Pages, Footnotes/Endnotes, Table of Contents, Variables, Expressions, Links, Comments, Files, Bookmarks, Tables, Pictures, Text Frames, Object Frames, or Scan Images.
  • Under Format you can choose the Default Format, Font, Paragraph, Footnotes, Formulas, Styles, use the Style Manager, Import Styles, or Create a Style From a Selection. Page Layout can also be formatted and you can Enable Document Headers and Footers.
  • The menu under Frames allows you to set Frame/Frameset Properties, Raise and Lower Frames, Bring to Front, Send to Back, Create a Linked Copy, Convert to Text Box, and to use the Frame Style Manager, Create Framestyle From Frame, change the Framestyle, Text Backgound Color, and Configure the Frame Border.
  • Table allows you to change the Table's Properties, Insert and Delete, Rows, and Columns, Join, Split and Protect Cells, Ungroup the Table, Delete a Table, use the Table Style manager and choose from several Tablestyles.
  • Selecting Tools gives you access to Spellcheck, Autocorrection, Change Case, Sort Text, Edit Personal Expressions, Add Expressions, set Custom Variables, Select Bookmarks, and Configure Mail Merge.
  • The Settings tab lets you choose which Toolbars you want open, Configure Autocorrection and Completetion, Configure Shortcuts, Toolbars, and Kword.
  • Select Help, or press the [F1] key, to open the KWord Handbook. Report a Bug and general information About KWord and KDE.
  • The row of icons under the top menu bar contains the most frequently used functions plus a few icons for text manipulation.
  • The third menu panel allows you to configure the appearance of your text, such as font selection, alignment, font, bullets, indentations, bolding, and italicizing.
  • Next to the work area is the Document Structure window which shows it's structure, and icons shortcuts to configure Frames.
  • The bottom panel shows the number of pages in the document, which page is in the work area window, whether Insert or Typeover is turned on, the Zoom in percentage, and the chosen measurement method.

For details on using KWord see this Tutorial.

Pre-Formatted templates can be downloaded from KWord Templates.

Gnome Office Applications

There are a number of office applications optimized for the Gnome desktop environment.

For more information on using these applications refer to the following documentation and support pages:

AbiWord

Abiword.png AbiWord is a GNOME word processing application.

  • Start the application by clicking on Applications > Office > AbiWord.
  • The functions of the top menu are:
  • File lets you create New documents, New using a Template, Open and Import Files, Save and Revert a file, Page Setup and Print, Close a file, or Quit the application. This menu will also show a list of recently opened files.
  • Edit allows you to Undo, Redo, Cut, Copy, and Paste, Clear, Select All, to Remove Headers and Footers, Find and Replace, Goto and to change the Preferences.
  • View lets you select the type of Layout, Toolbars, Ruler and Status Bar, Enable Formatting Tools, Show Formatting Marks, view a Presentation, Full Screen and Zoom in and out.
  • With the Insert button you can insert Breaks, Page Numbers, Date and Time, Fields, Text Box, Mail Merge Field, Symbols, Headers and Footers, Files, Bookmarks, Hyperlinks, Table of Contents, Footnotes, Endnotes, Equations, Clip Art, Pictures. Objects, such as GNOME Office Charts, and Direction Markers.
  • Under Format you can format Fonts, Paragraphs, add Bullets and Numbering, Text Box, Images, Columns, Tabs, Headers/Footers, Footnotes and Endnotes, Table of Contents. You can also Align and Format text, add a Page Background, and Create and Modify Styles.
  • From the Tools drop-down menu you can Check Spelling, Set the Language, Word Count, access the Thesaurus, GDict Dictionary, Translators, Edit an Image via GIMP, Google Search, Summarize the document, URL Dictionary, Wiki Encyclopedia, change style with the Stylist, pull up the Document History and Revisions. You can also see the installed Plug-ins and install new ones, execute helper Scripts that you have created, and perform Mail Merge.
  • Table allows you to Insert, Delete, Select, and manipulate the Table's Cells. You can also format and merge a Table's Cells, Rows and Columns, Convert Text to a Table, Convert a Table to Text and turn on Autofit Table.
  • With the Collaborate menu you can Share a Document, or Documents, and manage the collaboration Accounts.
  • Selecting Documents lets you open a New Window that lists any open documents.
  • Select Help, or press the [F1] key, to open the Help Contents, Search for Help, Check for Updates, Report a Bug, and see general information About GNOME Office and About AbiWord.
  • The row of icons under the top menu bar contains the most frequently used functions that are listed in the top menu.
  • The third menu panel allows you to configure the appearance of your text, such as font selection, alignment, font, bullets, indentations, bolding, and italicizing.
  • The panel at the bottom of the document contains a window that shows the number of pages in the document and which page is currently displayed, an indicator that Type-Over or Insert is turned on, page layout view, and language in use.

For details on using AbiWord see the Tutorial and HowTo Manual.

You can download these Plug-ins, for AbiWord, if they are not already installed.

Gnumeric

Gnumeric.png Gnumeric is a GNOME Spreadsheet.

  • Start the application by clicking on Applications > Office > Gnumeric Spreadsheet.
  • Major functions of the top menu are:
  • File to create New documents, Open, Save, Page Setup, Set, Clear and Show the Print Area. File also provides options to Print, Send To an email address, view and add to the program's Properties, set Preferences, access a Full History, and Close a file, or Quit the program.
  • Edit allows Undo, Redo, Cut, Copy, and Paste, and Fill, Clear, and Delete Rows, Columns, and Cells. Edit also provides options to Find, Replace or Goto a Cell, manage the Sheets, Select various ranges in the spreadsheet, and Recalculate.
  • View allows for creation of a New View of the workbook, the ability to Freeze Panes, select a different Workbook, choose Toolbars, View Statusbar, Full Screen and Zoom in and out.
  • Use the Insert menu to insert Cells, Columns, Rows, Charts, Images, Functions, Names, Comments, Hyperlinks and Special fields such as Current Date, Current Time, and Current date and time.
  • Under Format the Cells, Rows, Columns, Sheets and Workbook can be formatted and Preferences changed. Use Autoformat to format a region of cells according to a pre-defined template.
  • Tools provides Auto Correct, Auto Save, Goal Seek, Solver, View and Add Scenarios, Simulation, Statistical Analysis, and manage Plug-ins.
  • Selecting Data allows manipulation of the data such as Sort, Filter, Validate, Consolidate, create a Table, Group and Outline, parse Text to Columns, and Get External Data.
  • Select Help > Contents, or press the [F1] key, to open the Gnumeric help manual, Gnumeric on the Web, Live Assistance, or Report a Problem,.
  • The row of icons under the top menu bar contains the most frequently used functions that are also included in the top menu.
  • The third menu panel allows you to configure the appearance of your data, such as font selection, alignment, font, bullets, indentations, bolding, and italicizing.
  • The fourth panel shows the address of the cell you are pointing to and the data window shows what the cell contains.
  • The panel at the bottom of the spreadsheet shows which spreadsheet is currently selected, how many worksheets are in the file, and a function's result of the cell you are pointing too.
  • Worksheets can be added, or changed, with:
  • A right mouse click on one of the [Tabs], then choose from the menu.
  • Or going to the top menu panel and click on Edit > Sheet > make your selection.

For details on using Gnumeric see this Tutorial

gLabels

Glabels.png gLabels is a light weight GNOME application for creating labels, business cards, and CD/DVDs.

Start the application by clicking on Applications > Office > gLabels Label Designer.

  • Major functions of the top menu are:
  • File lets you create a New project, Open, Open Recent files, Save, Save As, Print, change Properties, bring up the template Designer, Close a file, or Quit the program.
  • Edit allows you to Cut, Copy, and Paste, Delete, Select All, Unselect All and change the Preferences.
  • View lets you choose Toolbars, customize the Toolbars, turn on the Grid and Markup, and Zoom in and out.
  • With the Objects button you can Select Mode, Create Text, a Box, Line Ellipse Image, a Barcode, define the Order, Rotate/Flip, Align Horizontal or Vertical, and Merge Properties.
  • Select Help > Contents, or press the [F1] key, to open the gLabel's help manual, or see general information About the program.
  • The row of icons under the top menu bar contains the most frequently used functions that are also included in the top menu.
  • The third menu panel is grayed-out until you select a New project or Open an existing file. These icons allow you to Select, move and modify objects, Create text object, Create box/rectangle object, Create a line object, Create ellipse/circle object, Create Image Object, Create a Barcode, Zoom in and out, and Edit merge properties.
  • The panel at the bottom of the work window lets you configure the appearance of your data, such as font selection, bolding,italicizing, alignment, and text and line color.,

For more information on using this application visit gLabel's web page


Previous Page - Communications (Email, IM) Table of Contents Next Page - Financial Software