Architectures/MIPS/BuildIssues

From FedoraProject

< Architectures | MIPS(Difference between revisions)
Jump to: navigation, search
(Created page with '== Built without java == *libtool *gettext *tzdata *setools *bison *subversion *pl *tetex-tex4ht == Built without test == *flac *mysql == MIPS specific patches or configuration...')
 
m
Line 1: Line 1:
== Built without java ==
+
== Java issue ==
*libtool
+
Some packages can't be built with java support as we don't have OpenJDK yet
*gettext
+
* avahi
*tzdata
+
* bison
*setools
+
* ca-certificates
*bison
+
* ecj: bootstrap
*subversion
+
* java-1.5.0-gcj: need bootstrap = 1
*pl
+
* setools
*tetex-tex4ht
+
* tetex-tex4ht
 +
* tzdata
  
== Built without test ==
+
== MONO issue ==
*flac
+
Some packages can't be build with MONO support as we don't have MONO binaries yet
*mysql
+
* avahi
  
== MIPS specific patches or configurations ==
+
== MIPS specific patches needed ==
*pstoedit: disable libEMF
+
* filesystem: we have /lib32 and /usr/lib32 in N32 systems
*avahi: no mono
+
* gc: libatomic_ops included in gc needs MIPS support code
*cloog: without ppl
+
* gdb: needs MIPS support code
*gcc: without cloog, ppl, multilib, test
+
* gmp: needs ABI patch
*metacity: without libcanberra, control-center
+
* gnupg: needs MIPS support code
*graphviz: without java, ocaml, R, mono
+
* guile: needs MIPS support code
*java-1.5.0-gcj: bootstrap = 1
+
* libaio: needs MIPS support code
*tcl: rpmbuild --define "sdt 0"
+
* libatomic_ops: needs MIPS support code
*ecj: bootstrap
+
* libgcrypt: needs MIPS support code
 +
* openssl: needs MIPS support code
 +
* mpfr: needs MIPS support code
 +
* redhat-rpm-config: support of mips architecture in rpmrc added
 +
* rpm: support of mips architecture in rpmrc added
 +
* systemtap: needs MIPS support code
 +
* tcp_wrapper: weak_symbol compile error, need #include <tcpd.h>
 +
 
 +
== Compile time / build parameter issue ==
 +
* curl: disable valgrind
 +
* elfutils: tests always fail. disable test
 +
* gcc: build without cloog, ppl, multilib
 +
* glibc: tzdata-update can't be built, skipped
 +
* metacity: -Werror on variable casting
 +
* pstoedit: disable libEMF
 +
* vala: disable devhelp
 +
 
 +
== F12 GA version not working, need update, not MIPS specific ==
 +
* gobject-introspection: compile option issue, fixed in F12 update RPMs

Revision as of 16:51, 27 March 2010

Contents

Java issue

Some packages can't be built with java support as we don't have OpenJDK yet

  • avahi
  • bison
  • ca-certificates
  • ecj: bootstrap
  • java-1.5.0-gcj: need bootstrap = 1
  • setools
  • tetex-tex4ht
  • tzdata

MONO issue

Some packages can't be build with MONO support as we don't have MONO binaries yet

  • avahi

MIPS specific patches needed

  • filesystem: we have /lib32 and /usr/lib32 in N32 systems
  • gc: libatomic_ops included in gc needs MIPS support code
  • gdb: needs MIPS support code
  • gmp: needs ABI patch
  • gnupg: needs MIPS support code
  • guile: needs MIPS support code
  • libaio: needs MIPS support code
  • libatomic_ops: needs MIPS support code
  • libgcrypt: needs MIPS support code
  • openssl: needs MIPS support code
  • mpfr: needs MIPS support code
  • redhat-rpm-config: support of mips architecture in rpmrc added
  • rpm: support of mips architecture in rpmrc added
  • systemtap: needs MIPS support code
  • tcp_wrapper: weak_symbol compile error, need #include <tcpd.h>

Compile time / build parameter issue

  • curl: disable valgrind
  • elfutils: tests always fail. disable test
  • gcc: build without cloog, ppl, multilib
  • glibc: tzdata-update can't be built, skipped
  • metacity: -Werror on variable casting
  • pstoedit: disable libEMF
  • vala: disable devhelp

F12 GA version not working, need update, not MIPS specific

  • gobject-introspection: compile option issue, fixed in F12 update RPMs