Architectures/ARM/Quality Assurance/Device Tree testing

From FedoraProject

Jump to: navigation, search

Contents

Fedora 18

kernel-3.6.0-1.fc18

To test device tree, the kernel was installed and uboot updated to the latest version available in Koji.

Hardware Who Boot Uboot Version uEnv/boot.cmd .dtb file fpaste of boot Notes
Versatile Express (Qemu) pwhalen
Pass pass
qemu-system-arm qemu-system-arm vexpress-v2p-ca9.dtb fpaste using patched version of qemu - BZ
Pandaboard pwhalen
Fail fail
U-Boot 2012.07 uEnv.txt omap4-panda.dtb fpaste
Trimslice pwhalen
Fail fail
U-Boot 2012.04.01-1.01 boot.cmd tegra20-trimslice.dtb fpaste

kernel-3.6.0-3.fc18

To test device tree, the kernel was installed and uboot updated to the latest version available in Koji.

Hardware Who Boot Uboot Version uEnv/boot.cmd .dtb file fpaste of boot Notes
Versatile Express (Qemu) pwhalen
Pass pass
qemu-system-arm qemu-system-arm vexpress-v2p-ca9.dtb fpaste using patched version of qemu - BZ
Pandaboard pwhalen
Fail fail
U-Boot 2012.07 uEnv.txt omap4-panda.dtb fpaste continual loop
Pandaboard pwhalen
Fail fail
U-Boot 2012.10 uEnv.txt omap4-panda.dtb fpaste continual loop
Trimslice U-Boot 2012.04.01-1.01 boot.cmd tegra20-trimslice.dtb

kernel-3.6.1-2.fc18

To test device tree, the kernel was installed and uboot updated to the latest version available in Koji.

Hardware Who Boot Uboot Version uEnv/boot.cmd .dtb file fpaste of boot Notes
Versatile Express (Qemu)
Pandaboard parasense
Pass pass
U-Boot 2012.07 uEnv.txt omap4-panda.dtb fpaste Appended the dtb to zimage, ran mkimage, updated uEnv.txt to point at custome uImage.
Trimslice parasense
Pass pass
U-Boot 2010.09-1.03-00006-ga52694f tegra20-trimslice.dtb fpaste The dtb loads out of boot.scr, but does not get applied (no /proc/device-tree). Using an appended dtb kernel works!
Trimslice parasense
Pass pass
U-Boot 2012.04.01-1.01 tegra20-trimslice.dtb fpaste Tried loading the dtb in boot.scr AND appending the dtb. In the first case the dtb loads fine, but then boot gets stuck at "starting kernel ...". In the later case, the appended kernel starts but gets stuck looking for the rootfs, right before the initrd loads. To make it work had to redo the boot.cmd to have root=/dev/mmcblk0p3. TL;DR: appended kernel works.

 ?

To test device tree, the kernel was installed and uboot updated to the latest version available in Koji.

Hardware Who Boot Uboot Version uEnv/boot.cmd .dtb file fpaste of boot Notes
Versatile Express (Qemu) qemu-system-arm qemu-system-arm vexpress-v2p-ca9.dtb using patched version of qemu - BZ
Pandaboard U-Boot 2012.07 uEnv.txt omap4-panda.dtb
Trimslice U-Boot 2012.04.01-1.01 tegra20-trimslice.dtb